ckeditor

techniques de dépannage ckeditor (ou autre module récalcitrant)

J'ai eu divers bugs liés à ckeditor (depuis un an, sur ce site dont je paie l'hébergement), Views, sans parler des omega...

Tout admin de drupal (ou toute autre application informatique), connait le phénomène des "bugs qui se déplacent". En cas d'erreur, on regarde les logs - et quand on n'y trouve RIEN d'inhabituel, on vit avec si c'est mineur - car l'on sait que cela peut aussi "retomber en marche".

En résumé, techniques de dépannage d'un module récalcitrant...

  1. après update.php, vider le cache drupal
  2. vider les caches du navigateur : CTRL F5 est insuffisant. Tester (firefox) CTRL+MAJ+SUPP. Et/ou tester avec un autre navigateur (IE, opéra...)
  3. désactiver les caches de drupal, désactiver la compression des .JS (voir des .css) ; tester, retourner au point 1
  4. documenter: consulter le README.TXT et site web du/des modules impliqués, vérifier l'installation des modules (versions, prérequis, notes des dev, droits des fichiers et dossiers chez l'hébergeur...) car c'est toujours utile smiley
  5. si toujours ko, pas d'erreurs dans les logs ni aucune piste:
    Tenter une modif mineure, sauver le user (ou la conf du module) et retester ; retourner au point 1.
  6. Utiliser Firebug: vérifier les droits des users (tester avec un nouvel user créé),
    ainsi que la conf (via URL admin de drupal) des modules suspectés (que l'on vient de modifier ou de mettre à jour).
  7. Penser à relancer son instance la nuit, regarder les incidents chez l'hébergeur, et retourner au point 1 (faire un backup bien sur)
  8. revenir à un thème de base, désactiver d'autres modules... c'est à dire sur une machine de dev si le dit bug touche la prod :)

 

conf ckeditor - exclude barre outil

ID for excluding or including this element is admire_grunge:matching@node/15/edit.edit-match-1-question.

is admire_grunge:matching@node/15/edit.edit-match-1-answer.
is admire_grunge:matching@node/15/edit.edit-match-1-feedback.

taxonomy toolkit

Taxonomy tooltip 7.x-1.1 avec ckeditor et admin menu -> drole de bug, qui ressemble à un bug js qui a impacté:

Styles CKEditor doc

Tags HTML autorisés : <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <caption> <tbody> <tr> <td> <em> <b> <u> <i> <strong> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <embed> <object> <param> <strike>

comment intégrer dans un article une image chargée via le module Media ?

Forums:

Sans Media: cliquer sur icone image "insérer image". Avec Media : utiliser l'icone icone Media

Conf Media File Selector Widget / admin/structure/file-types/manage/image/display

Pages

S'abonner à RSS - ckeditor