drupal 8

Module Date

https://www.drupal.org/project/date et doc (générale) à drupal.org/node/262062 et pour la v7 drupal.org/node/1455554

Date drupal 6 requiert ctools, pas la v7 (7.x-2.8).

Le readme de la v7 indique "The API uses the PHP 5.2 date functions to create and manipulate dates." ?!?

Module Field Formatter Class

https://www.drupal.org/project/field_formatter_class pour ajouter des classes au wrapper HTML pour des affichages de champs (js et css peuvent ainsi les cibler).

Langues Drupal 8

http://hojtsy.hu/blog/2013-jun-12/drupal-8-multilingual-tidbits-2-more-c...

Un site italien aura la conf: Langues drupal 8 d'un site qu'il n'a qu'une seule langue (core)
Transliteration est intégré au core.

On installe directement drupal en francais, et les modules suivants sont dispo (core):

Trusted host Drupal 8

En testant drupal 8 j'ai eu un message juste après l'insall à admin/reports/status : "The trusted_host_patterns setting is not configured in settings.php." et un lien https://www.drupal.org/node/1992030

Là, je découvre :

Balise hreflang

Le module i18n n'ajoute pas la balise hreflang.

Solution: Alternate hreflang https://www.drupal.org/project/hreflang

Ne requiert rien, fonctionne bien avec entity_translation (je ne l'ai pas testé avec entity_translation).

Aucune configuration à faire avec i18n, aucune permission à donner, il faut juste activer le module.

Module themekey

Module schemaorg Schema.org

https://www.drupal.org/project/schemaorg (7.x-1.0-rc1 ou )

Bing, google et Yahoo utilisent Schema.org pour afficher le résultat des recherches.
Schema.org sera incorporé à drupal 8 et ne sera pas porté pour drupal 6.
A ne pas confondre avec le module schema (sql).
Si avec Drupal Commerce, il faut utiliser le module Good Relations for Drupal Commerce au lieu du schema.org de ce module (schemaorg).

Liste des schemas (tous sur 1 page) dont TechArticle ; Book et LiteraryEvent ; Blog ; DataCatalogSoftwareApplication ; WebPage Language  ou Organization.
Voir aussi chez Google support.google.com/webmasters/answer/2650907 et google.com/webmasters/tools/

Vers ma page Docs schemas et SEO-web sémantique.

Versions de PHP requises pour drupal

bootstrap: un thème de base pour drupal 7

https://www.drupal.org/project/bootstrap et doc à https://www.drupal.org/node/1976938 et http://drupal-bootstrap.org

Requiert JQuery (via le module jQuery Update ).  Pour  Bootstrap 3 (7.x-3.x): jQuery - 1.9.0+

Fichier attachéTaille
Plain text icon settings.txt8.46 Ko

Drupal 8 : beta

drupal-8.0.0-beta4 en /var/www/dru8 de la vm14

Sur la vm14, drush 6.4.0 ne gère pas cette version de drupal

Requiert: Apache 2 ou Nginx 1.1 http://www.nginx.com/, PHP 5.4.5 et MySQL 5.0.15 (ou +)

https://www.drupal.org/requirements   https://www.drupal.org/drupal-8.0

 

Pages

S'abonner à RSS - drupal 8