srv

OS coté serveur (windows 2012, 2008 R2...), applications/services qui tournent sur un serveur, voire notions serveurs

Test VirtualBox : Ubuntu 17 serveur avec Webmin

Installation LAMP sur Ubuntu server 17.10 (kernel Linux 4.13.0-36-generic) via VirtualBox (VBox).

Conf VBox : hostname srvb1 sur d2/drupal/VirtualboxSrv/vb1, 2 cpu, 3Go, accès par pont (mode bridge) Mode promiscuité: auto les VM.

Installation de Webmin (version 1.870), on accède au serveur via le browser en https port 10000 par défaut. Le disque vdi fait 10 Go, il reste un peu moins de 4 Go.

Maj Janvier 2018 -> php 7.1

Sur pi2 (case transparent)

Maj 10 janvier 2018

Lors maj systeme et firmware, en janvier 2018, la maj de php 7.0 (lié à apache) vers 7.1 a mis la grouille.

Drupal est en v 8.4.4 et utilise nginx. Composer 1.6.2 ; drush 8.1.15

Versions de php

Un  dpkg -l | grep samba montre du php 5, 7.0 et 7.1    -> ok

sudo nginx -t   --> ok

Il manquait php-curl ..., Il fallait configurer le user fpm... Puis un composer update montre qu'il manquait php-mbstrings

 

 

maj dec 2017

maj debian, firmware :

sudo apt-get update && sudo apt-get -y upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo rpi-update
reboot

maj composer et drupal 8

cd drucomp ; composer update

composer require 'drupal/views_slideshow: ^4.6'
composer require 'drupal/admin_toolbar: ^1.21'

core drupal 8.4.3-> soucis de date php 32b

+ composer require 'drupal/paragraphs: ^1.2'
composer require 'drupal/entity_browser:^1.4'  et theme boostrap 3.7

 

Notes CFT et TSM

Installer Subsonic

http://www.subsonic.org/pages/help.jsp

gestion de zic et films, stream, transcoding (accès via browser à http://localhost:4040). Voir leur démo.

Par défaut :

Installer drupal 8 (drupal-composer)

Regroupe mes notes d'installation de drupal 8 (sur diverses vm, voir pi, lamp ou lemp).

Vers mes notes sur le local.settings.php (nouveau dans drupal 8), prises lors d'un test sur pi (nginx sous jessie).

srv17 : install drupal 8

Sur srv ubuntu17 (lamp php7), composer 1.2.2 installé globalement. Drupal8 avec drush 8.1.11, Librairie GD 2.2.4.
(Sur cette vm, il y a aussi un drupal 7 en /var/www/dru7).

Pages

S'abonner à RSS - srv